Degraded performance
Incident Report for Classcraft
Resolved
This incident has been resolved.

Thanks for your patience!!
Posted 4 months ago. Apr 30, 2019 - 17:17 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. Apr 30, 2019 - 14:12 EDT
Investigating
Certain parts of our infrastructure are showing degraded performance. We are looking into the issue. Hang tight!
Posted 4 months ago. Apr 30, 2019 - 13:09 EDT
This incident affected: Classcraft Game.