Maintenance
Incident Report for Classcraft
Resolved
Thanks for your patience. This issue has now been resolved. Please reach out to the support team if you are still having the issue.
Posted about 1 year ago. Mar 19, 2018 - 13:52 EDT
Identified
We will shortly be conducting maintenance to remedy the issues some of you have reported. Some may experience degraded performance or be unable to access the game. Stay tuned for more information.
Posted about 1 year ago. Mar 19, 2018 - 12:32 EDT