Degraded Performance
Incident Report for Classcraft
Resolved
Everything is back to normal! Thanks for your patience.
Posted over 2 years ago. May 26, 2016 - 19:35 EDT
Investigating
Certain parts of our infrastructure are showing degraded performance. We are looking into the issue. Hang tight!
Posted over 2 years ago. May 26, 2016 - 17:02 EDT