Performance degradation
Incident Report for Classcraft
Resolved
This incident has been resolved.

Thanks for your patience!!
Posted May 13, 2019 - 11:30 EDT
Investigating
Certain parts of our infrastructure are showing degraded performance. We are looking into the issue. Hang tight!
Posted May 13, 2019 - 11:22 EDT
This incident affected: Classcraft Game.