Performance issue
Incident Report for Classcraft
Resolved
This incident has been resolved.

Thanks for your patience!!
Posted 4 months ago. May 09, 2019 - 12:28 EDT
Investigating
Certain parts of our infrastructure are showing degraded performance. We are looking into the issue. Hang tight!
Posted 4 months ago. May 09, 2019 - 12:03 EDT
This incident affected: Classcraft Game.