Server unreachable
Incident Report for Classcraft
Resolved
This incident has been resolved.
Posted about 2 years ago. May 04, 2016 - 13:27 EDT
Investigating
game.classcraft.com is unresponsive because of a cloud infrastructure problem. The problem resides with one of our service providers and is beyond our control. We apologize for any inconvenience this is causing you and your classroom. The game should be back online shortly.
Posted about 2 years ago. May 04, 2016 - 12:52 EDT