Server Slowdown
Incident Report for Classcraft
Resolved
The issue has been resolved, thank you for your patience. We'll continue monitoring the situation.
Posted about 2 years ago. Feb 23, 2016 - 12:14 EST
Identified
The servers are experiencing unusual load. We are currently adding memory to the system. Operation should take 15 minutes.
Posted about 2 years ago. Feb 23, 2016 - 11:20 EST