Intermittent issue
Incident Report for Classcraft
Resolved
This incident has been resolved.
Posted 11 months ago. Jun 01, 2017 - 13:23 EDT
Identified
We're experiencing unexpected issues. Intermittent connection may occur. We appreciate your patience as we resolve the problem.
Posted 11 months ago. Jun 01, 2017 - 12:55 EDT