Intermittent issue for: https://help.classcraft.com/
Incident Report for Classcraft
Resolved
Thanks for your patience. This issue has now been resolved. Please reach out to the support team if you are still having the issue.
Posted about 1 month ago. Apr 19, 2018 - 15:45 EDT
Investigating
We are aware that some users may be experiencing issues accessing our support tools. We are working to get this resolved as quickly as possible. Thank you for your patience.
Posted about 1 month ago. Apr 19, 2018 - 11:05 EDT