Maintenance
Incident Report for Classcraft
Resolved
Thanks for your patience. This issue has now been resolved. Please reach out to the support team if you are still having the issue.
Posted 10 months ago. Oct 24, 2017 - 10:47 EDT
Update
We are conducting maintenance to remedy the student access issues some of you have reported. You may experience degraded performance. Stay tuned for more information and thank you for your patience as we sort this out!
Posted 10 months ago. Oct 24, 2017 - 10:21 EDT
Identified
We will shortly be conducting maintenance to remedy the issues some of you have reported. Some may experience degraded performance or be unable to access the game. Stay tuned for more information.
Posted 10 months ago. Oct 24, 2017 - 10:15 EDT